启迪大众分享网

多条均线粘合后公式

均线粘合的公式

股价一段时间在横盘状态啊,振幅很小

均线粘合公式

选股公式条件1、四线粘合;2、低位二次金叉;3、然后一阳穿四线,同时放量(或者第二天补量);成功率39--37,还可以吧V0:=EMA(C,5);V1:=EMA(C,10);V2:=EMA(C,15);V3:=EMA(C,30);V4:=EMA(C,60);M1:=1000*V1/V4<=1015 AND 1000*V1/V4>=975;M2:=1000*V2/V4<=1020 AND 1000*V2/V4>=980;M3:=1000*V3/V4<=1015 AND 1000*V3/V4>=985;M4:=M1 AND M2 AND M3 AND CROSS(V0,V1);M5:=M1 AND M2 AND M3 AND CROSS(V0,V3);M4 OR M5; 三线粘合金叉:A5:=MA(C,5);A10:=MA(C,10);A30:=MA(C,30);AA:=CROSS(A5,A10);BB:=CROSS(A5,A30);CC:=CROSS(A10,A30);COUNT(AA,3)=1 AND COUNT(BB,3)=1 AND COUNT(CC,3)=1; 三线粘合向上加成交量:36--9。6a5:=ma(c,5);a10:=ma(c,10);a30:=ma(c,30);均线粘合:=count(max(max(a5,a10),a30)/min(min(a5,a10),a30)<1.03,5)>=3;向上突破:=a5>ref(a5,1)and a10>ref(a10,1)and a30>ref(a30,1)and c>a5 and c>a30;成交量突破:=v/ma(v,5)>2 and ma(v,5)>ma(v,10);均线粘合 and 向上突破 and 成交量突破;多条均线粘合:成功率--35--15a13:=ma(c,13);a21:=ma(c,21);a34:=ma(c,34);a55:=ma(c,55);a120:=ma(c,120);a240:=ma(c,240);max(max(max(a13,a21),max(a34,a55)),max(a120,a240))/min(min(min(a13,a21),min(a34,a55)),min(a120,a240))<1.1 and a13>ref(a13,1)and a120>ref(a120,1);三线粘合:AA:=MA(C,5);BB:=MA(C,10);DD:=MA(C,30);A1:=ABS((AA-C)/C);A2:=ABS((BB-C)/C);A3:=ABS((DD-C)/C);B:=A1<0.05 AND A2<0.05 AND A3<0.05;FILTER(B,10)=1 ;通达信均线粘合选股公式MA1:=MA(CLOSE,5);MA2:=MA(CLOSE,10);MA3:=MA(CLOSE,20);MA4:=MA(CLOSE,60);MA5:=MA(CLOSE,120);MA6:=MA(CLOSE,250);A:MAX(MAX(MA1,MA2),MA3),LINETHICK0;B:MIN(MIN(MA1,MA2),MA3),LINETHICK0;三线粘合:IF(RANGE(100*(A-B)/B,0,5),100*(A-B)/B,DRAWNULL),LINETHICK0;SA:MAX(MAX(MA1,MA2),MAX(MA3,MA4)),LINETHICK0;SB:MIN(MIN(MA1,MA2),MIN(MA3,MA4)),LINETHICK0;参数可以自行设置:D为均线多头排列天数,N1,N2,N3为涨幅限制,可根据自己需要设置!再结合其他指标组合选股!不足之处请高手指点!D为均线多头排列天数,设为2-3天都可,N1,N2,N3为涨幅限制,我一般设为1.5或是2(这个可根据自己要求设),具体如下:参数名  缺省   最小  最大   步长D      1     1    20     1N1     1     1    20     0.5N2     1     1    20     0.5N3     1     1    20     0.5源码:MA5:=MA(CLOSE,5);MA10:=MA(CLOSE,10);MA20:=MA(CLOSE,20);MA30:=MA(CLOSE,30);A1:=MA5>MA10 AND MA10>MA20 AND MA20>MA30 AND ALL((MA5>MA10 AND MA10>MA20 AND MA20>MA30),D);A2:=((MA5-MA10)/MA5)*100<N1 AND ((MA10-MA20)/MA10)*100<N2 AND ((MA20-MA30)/MA20)*100<N3;A3:=A1 AND A2;FILTER(A3,5);三线合一  时间持续一日即可 当天盘后选至于相距多少算粘合我不知道怎么表达 下面是个均线三线粘合的选股公式 这样的粘合就行了X1:=ABS(MA(C,10)/MA(C,20)-1)<0.01;X2:=ABS(MA(C,5)/MA(C,10)-1)<0.01;X3:=ABS(MA(C,5)/MA(C,20)-1)<0.01;MA(C,5)>REF(MA(C,5),1) AND X1 AND X2 AND X3;MA6,18,25,45)均线粘合选股A1:=MA(C,6);A2:=MA(C,18);A3:=MA(C,25);A4:=MA(C,45);AA:=(A1+A2+A3+A4)/4;UP:=AA*(N/100)+AA;DN:=AA-AA*(N/100);COUNT(BETWEEN(A1,UP,DN) AND BETWEEN(A2,UP,DN) ANDBETWEEN(A3,UP,DN) AND BETWEEN(A4,UP,DN),M)=M;CLOSE>A1 AND CLOSE>A2 AND CLOSE>A3 AND CLOSE>A4;

求老师写个五条均线粘合,放2倍量站上五条均线的选股公式

M5:=MA(C,5); M10:=MA(C,10); M20:=MA(C,20); M30:=MA(C,30); M60:=MA(C,60); M120:=MA(C,120);
A1:=MAX(M60,MAX(M30,MAX(M20,MAX(M5,M10))));
A2:=MIN(M60,MIN(M30,MIN(M20,MIN(M5,M10))));
(A1-A2)/A2*100<n;
粘合距离多少? 自己修改N的值吧。

多条均线粘合的公式怎么写,请写出源码来。谢谢......................

给你一个例子,通达信三线粘合指标公式,图片演示看源码下面网址里.
M1:MA(CLOSE,17)+ABS(MA(CLOSE,17)-REF(MA(CLOSE,17),1)),COLORGREEN;
M2:MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1),COLORGREEN,LINETHICK1;
M3:IF(MA(CLOSE,17)<M2,M2,MA(CLOSE,17)),COLORGREEN,LINETHICK1;
支撑线:M3-(EMA(C,3)-M3),COLORFF8080,LINETHICK1;
支强:IF(支撑线>REF(支撑线,1),支撑线,DRAWNULL),COLORGREEN,LINETHICK2;
J1:=BACKSET(M1>REF(M1,1),2);
IF(J1,M3,DRAWNULL),COLORMAGENTA,LINETHICK2;

(就要两条均线粘合的选股公式)

1 abs(ma(c,62)-ma(c,133))/ma(c,133)<0.005
2 将上面的ma改为expma即可。

求通达信量均线粘合选股公式

p:=max(ma(v,35),ma(v,135))/min(ma(v,35),ma(v,135));
and(p<1.03,cross(ma(v,135),ma(v,5)),ma(v,5)+ma(v,35)+ma(v,135)<6000,C<ref(c,1));
p取值 1~+∞,越小粘合度越高。
符合选股条件,满足公式条件 输出 1,否 输出 0。